Forums Help & support PDFs Will Not Encrypt — Open in Other Application Error Message

This topic contains 3 replies, has 2 voices, and was last updated by  Svante 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #3921 Reply


    Just installed AxCrypt 2.1.1444.0-x86 and none of my PDFs will encrypt, either PDFs I created by ‘save to PDF’ via Word, or PDFs sent to me from other sources. Keep getting error message “[Path/Filename.pdf] is open in another application. Please close it and try again.” even though the file is not open in another application. All other file formats I have tried so far encrypt and decrypt just fine (.doc, .ppt, .jpg, etc.) using the same method I’m using with the PDFs. I hope there is an easy fix to this as this software will be worthless to me if PDFs will not encrypt. Running Windows Vista Home Premium 32-bit. Adobe Reader 9.5 (I’ve tried installing higher versions of Adobe Reader twice and they don’t function on my system properly).

    #3922 Reply



    Ensure for example Acrobat is closed.

    You can also find out what process is locking the file. Google for example

    File is locked by another process

    There are many ways.


    #3923 Reply


    So I believe I just figured this out by myself. It appears to have been Windows Explorer itself causing the problem. I had the Preview Pane activated in Windows Explorer (Organize>Layout>Preview Pane) and this appeared to be causing AxCrypt to recognize the PDF files as “open in another application.” Why AxCrypt did not recognize any other file type (Word docs, JPEG photos, PPT spreadsheets, etc.) as “open in another application” when the Preview Pane was activated, I can’t say, but turning off the Preview Pane has allowed the PDFs I have tested so far to encrypt and decrypt fine.

    Also, just to respond to your earliest post, I don’t have Acrobat so it wasn’t open, and Adobe Reader was not open either (according to Tool Bars and Task Manager). And sorry if I misunderstood your earlier point, but I am not sure whether the file being “locked” is the same thing as the file being recognized as “open in another application.” The PDF files did not appear to be “locked” since I could open them, move them, rename them, delete them, and so on. I just couldn’t get the Encrypt function to work with AxCrypt given the repeated error message about the file being open in another application.  When I Googled the phrase you mentioned, I saw lots of people talking about not being able to delete, rename or copy “locked” files (not my problem) or running Command line utilities (HoboCopy?) or downloading even more software (Unlockit?) to unlock locked files. Glad I didn’t go there.

    Thank you for your prompt reply.

    #3924 Reply


    Hello LA,

    Thanks for letting us know. Normally ‘open in another application’ is just a supposedly user-friendly way of saying ‘the file is locked by another process’, and it would indeed normally stop rename/delete etc. However, in this case, rename/delete etc is done by the Windows Explorer process so it’s locked by itself and can thus handle the situation – I’m guessing.

    I’ll see if I can reproduce this, and see if there’s some way to handle it better.


Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: PDFs Will Not Encrypt — Open in Other Application Error Message
Your information:

Upload Images

Drag & drop, tap, or click