Forums Bugs & issues Not accepting password, even resetted from website, still no Reply To: Not accepting password, even resetted from website, still no

#8287 Reply

Svante
Keymaster

Hello Jeff,

I can’t be sure of course, but I don’t think I’m misunderstanding.

It’s a fundamental, and vital, property of encryption that without the key (password) the data cannot be retrieved and the password cannot be reset.

There are two entirely different mechanisms at work here, both using a password.

1) Sign in to the service, this is a case of authentication. The server will programmatically allow access if it determines the password is correct. A password reset is easy to implement here, it’s just about re-instructing the server in a trusted way just what the correct password is.

2) Encrypting data using a password derived encryption key. Here the password is used to derive an encryption key, which is used in a mathematical algorithm to transform (encrypt) your data using the key as the secret parameter. There is no server granting or denying access here. It’s just that either you have the right key or you don’t. You can’t perform a password reset. You can perform a pasword change, which will imply that somewhere something is first derypted using the old known key, and then encrypted again using the new.

There’s a longer discussion here:¬†https://www.axcrypt.net/blog/encryption-vs-authentication/ about the distinction.

From your description of the situation, it sounds like you can sign in to AxCrypt just fine, but when you try to open a file, you’re getting a dialog stating that you need to provide the file password.

If this is wrong, and I am in fact misunderstanding – please provide screen shots of where you’re stumped, and / or contact our support so we can look at your particular account.