Forums Help & support AX 1.7.3156 Failed to startup. Faulting application path.

This topic contains 9 replies, has 2 voices, and was last updated by  Svante 3 months, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #11013 Reply

    Milan

    Hi,

    Today my AxCrypt 1.7.3156 on Windows 10.0.17134  x-64 Home stopped working. The application returns Failed to startup AxCrypt. Error in system call to CFileName::RmDir() [SetCurrentDirectory(szDir)], Access is denied.

    I checked the Event log, it says:

    Faulting application name: AxCrypt.exe, version: 1.7.3156.0, time stamp: 0x52d7bcda
    Faulting module name: AxCrypt.exe, version: 1.7.3156.0, time stamp: 0x52d7bcda
    Exception code: 0xc0000409
    Fault offset: 0x00000000000a61c0
    Faulting process id: 0x26d0
    Faulting application start time: 0x01d42e28ab1203f9
    Faulting application path: C:\Program Files\Axantum\AxCrypt\AxCrypt.exe
    Faulting module path: C:\Program Files\Axantum\AxCrypt\AxCrypt.exe
    Report Id: fbaa1b08-4e80-4082-bd05-dd971d59db0b
    Faulting package full name:
    Faulting package-relative application ID:

    Any help apprecitated. (Although please do not reply just with “install the current 2.x version”, I remain with 1.7 for a good reason.)

    Thank you,

    Milan

    #11015 Reply

    Svante
    Keymaster

    Hello Milan,

    Please install the current 2.x version. ;-)

    Ok, seriously. The thing is, we don’t support or maintain version 1.7. In your case, though, since obviously AxCrypt has not changed – something else has.

    In this case, probably the location or permissions for the %TEMP% folder in Windows, which is where AxCrypt stores it’s temporary files.

    #11016 Reply

    Milan

    Hello Svante,

    Thank you for your quick reply and your suggestion. I verified the location of the %temp% folder in Windows, it is as usual and common:

    c:\Users\milan\AppData\Local\Temp

    Within Temp there is even a folder named axcrypt1. It is empty. I also checked the rights to both folders: Everyone R+W+SP, Administrators FC. My current user is in group of Administrators.

    I tried:

    1. Looked for any problems in the registry with scf /scannow (no problems).
    2. Solved some issues with Registry Repair application (no effect).
    3. Set path in Environment Variables to c:\Program Files\Axantum\AxCrypt (no effect).
    4. Unistalled and reinstalled AxCrypt several times (no effect).

    The application responses from the context menu just to the Language change and the About items, nothing else. It does not encrypt or decrypt. I hope to solve this soon, I use AxCrypt on daily basis.

    Thank you for your further insights,

    Milan

    #11017 Reply

    Svante
    Keymaster

    Hello Milan,

    There may also be locking of files involved. Have you rebooted (as you should also have been instructed several times during uninstall / install process)?

    The error message stems IIRC from AxCrypt trying to clean up it’s temporary folder (which it does during startup as well).

    #11018 Reply

    Milan

    Hello Svante,

    Yes, I have rebooted my PC and reinstalled AxCrypt several times while clearing any AxCrypt remains in between (in fact, the app does not require to reboot). I even tried to install AxCrypt-1.7.3180.0 with no success. Where is the AxCrypt temporary folder located please? In the Windows %temp%, in my case c:\Users\milan\AppData\Local\Temp\axcrypt1? It is empty now.

    It is a good point about locking files. But what is locked and where? There are quite a few background processes in the OS but nothing suspicious. I can paste and copy the list if necessary.

    While trying AxCrypt I make sure to test it on a simple *.txt file placed on desktop to avoid any priviliges problems.

    I just rebooted in Safe Mode without networking and voilà – AxCrypt worked. I understand something has changed in Windows 10 environment (terrible OS) but I can’t figure out what blocks AxCrypt and why clean unistall and reinstall doesn’t help.

    Thanks again, I am becoming desperate.

    Milan

    #11019 Reply

    Svante
    Keymaster

    Hi Milan,

    Thank you for the information, but this is the point where I will have to say what you don’t want to hear…

    Upgrade to version 2.

    As mentioned, we don’t support and we don’t maintain version 1.7 anymore. It’s old. Things around it changed. It could be something in Windows 10 (although I’m not sure about that either). But, this is what happens with software, and why it needs maintenance. Which we don’t do for 1.7…

    Perhaps you can tell us just what the critical reasons are for not using version 2?

    From what I understand you can at least access your files now, so there is no risk for data loss at this point.

    #11020 Reply

    Milan

    Hi Svante,

    Thank you for your suggestions. To make the story short, I fixed the problem and have AxCrypt 1.7 running again. Maybe this will help others in the future who will look for a solution in this tread:

    The issue was lost permissions to the %temp% folder, more specificaly missing the ‘SYSTEM’ with Full control which applies to ‘This folder, subfolders and files’. I removed the %temp% folder completely, rebooted (this way it got recreated with correct inherited permissions) and AxCrypt started to operate. I found the hint in the Microsoft forum. Thank you again for your help, Svante.

    I don’t want to owe you answer to your question what prevents me from installing 2.x version. Here are my critical reasons:

    1. My friends, colleagues and I naturaly use AxCrypt 1.x on several computers. Your FAQ says “Files secured with AxCrypt 2.x are not possible to open with AxCrypt 1.x.” I cannot accept that.
    2. When installing AxCrypt 2.x the app asks for my existing e-mail. One wouldn’t expect that in a cryptographic application. Frankly, I don’t see a reason why I should share any personal information and create an account at Axantum – I find it unnecessary, the application doesn’t need it for its operation. This applies even more to a password stored on-line. AxCrypt has always worked off-line and there’s no reason to change it. I never got over this.

    I have always liked AxCrypt in the old way very much and I have propagated it within my friends and colleagues. It works perfectly and does the job.

    If this is about business I will be happy to donate (why this option is missing in the new pages and remains only on Axantum.com?) as I don’t see any advantages for me to buy a Premium version especially when it is against my principles listed above.

    Keep up the good work,

    Milan

     

    #11021 Reply

    Svante
    Keymaster

    Hello Milan,

    Glad to hear you got it working again, so it was what I originally thought it was. Good job. I seem to recall that there were some versions of Adobe Acrobat that caused the problem after installation…

    As for your reasons of not wanting to upgrade, I appreciate you taking the tine. The first issue – that others will have to upgrade as well, can’t do much about that. If that was a universal principle, no software could ever evolve. You’d still be stuck with Word 1.0… So, yes, I recommend both you *and* your colleagues to upgrade!

    The second reason, we do use the email address for several vital functions. One of them being solving the problem of sharing files with others. We use modern public key cryptography in a very simple package to enable sharing of files with others without sharing any passwords. So, AxCrypt is also a key server – and this is a normal cryptographic function, and it does require some form of identification moniker. We choose to use the email address because we don’t consider this to be a secret, and we also specifically state that using AxCrypt itself should not need be kept secret. We don’t try to hide the fact that an encrypted AxCrypt file is encrypted with AxCrypt. AxCrypt is strong enough so it will not matter.

    Part of it is definitely about business! I’m happy to year you’re willing to donate, unfortunately not one in a thousand of the free users of AxCrypt will do so, and even you have not done so yet apparently except when this came up. So, the freeware donation model just did not work. I had the choice of sunsetting the whole project and shutting down, or trying to find a model where I could get some return for the time and effort spent.

    I do understand that there is a natural resistance to change, but sometimes things will just have to. With AxCrypt 1 and 2 this is the case.

    Of course you’re welcome to continue using AxCrypt 1 for as long as you like, or use AxCrypt 2 for free too. But, as time goes by, you’ll be more and more exposed to risk using old, unmaintained, unsupported software.

    #11022 Reply

    Milan

    Hello Svante,

    You are correct – the problem was most probably caused by Adobe Acrobat installation. Guess how I found about it – I tried to install the latest AxCrypt 2.x and it wouldn’t go through! Then I focused on the %temp% folder. Maybe something to add to the installer – validation of necessary permissions.

    Ad 1) I’m not stuck with Word 1.0 but some of my friends are with Word 97. But within LibreOffice/Word 2016 I have an option to save the file in various compatible formats for them. Does 2.x allow that?

    Ad 2) I might have to look deeper in this but I consider being able to share files without passwords based on e-mails vulnerable. I would feel unsafe to store my e-mail address along with my key on the internet. Why is it not optional but rather an obligation to run the application? The only password I use for AxCrypt 1.7 is in my head. When I die the files will go with me.

    I understand the business question. But as I read your forum, there are many of us with security concerns that prevent us from upgrading. And if we did – where is the income for you if the app can still be used for free?

    There are business models that work with try&buy, like Sublime Text. They occasionally remind you – if you like the product, please support it. And I sometimes do.

    I honestly did not know/remember about the possibility to donate until I wrote the post today. I just googled it. I originally downloaded the application from your site or somewhere else years ago and used it. I had no reason to visit your site. I might have thought you had different source of income that allows you to make many users happy in your free time (similar like Jan Fiala and his PSPad, glory to him). But good it’s still on the obsolete Axantum page – I just made a donation through it.

    Best to you and your team,

    Milan

    #11023 Reply

    Svante
    Keymaster

    Hello Milan,

    Thank you for the information and thank you for the donation!

    We don’t store passwords as such on our servers, and the security is not at all tied to an email address (although it may look so on the face of it) once a user has signed up and set a password. The security still rests 100% on keeping that passphrase strong and secret. That’s all.

    But, it’s all up to you! Good luck!

Viewing 10 posts - 1 through 10 (of 10 total)
Reply To: AX 1.7.3156 Failed to startup. Faulting application path.
Your information: