Forums Help & support AxCrypt for Mac OSX 10.12 Sierra

This topic contains 12 replies, has 2 voices, and was last updated by  David Blanchard 2 months, 2 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #4262 Reply

    Keith Rowe

    I have been using AxCrypt with Mac OSX 10. 11 El Capitan on my MacBook Pro successfully for some time but recently loaded the latest OSX 10.12 Sierra and cannot open the encrypted files. I am aware that AxCrypt are working on a Mac OS compatible upgrade but I need to be able to open the files ASAP. I have tried opening them on a Windows Vista 64 bit computer with the latest AxCrypt download for Windows 64 bit but an error message comes up saying that the files have an incorrect extension of ‘axe’.

    I have also tried opening the files using the Mac Time Machine back up system prior to the loading date of the Sierra OS but I think I would have to ‘Restore’ the complete El Capitan OS to get the files to open.

    Is there any quicker way of opening the files ??

    #4263 Reply


    Hello Keith,

    The absolutely fastest way is indeed to do it on a Windows computer, and use the portable / standalone download. You can then open them from within the program, no installation required.

    I’m not sure about your error message, I’m assuming that you mean “axx”, not “axe” but even so it indicates that you’ve not actually installed AxCrypt on the computer in question.

    If the above doesn’t help you, please attach a screen shot of the situation.

    #4264 Reply

    Keith Rowe

    Thank you Svante. First my apologies for trying error.  the error message reads —- has the wrong file name extension. It must be ‘.axx.”.  I have downloaded the Portable / standalone  and tried to use it without success – I still get the same error message . Please see the attached screen shot.

    #4268 Reply

    Keith Rowe

    Morning Svante,

    I have now been able to open the files on my Mac. The original files were created using ‘OpenOffice’ and then encrypted using AxCrypt on a Windows computer. Some years ago I transferred the files onto my Mac without any problems still using the AxCrypt encryption. After downloading OSX Sierra the desktop copies of the files could not be opened but opening the OpenOffice app all the files were listed and I could open them using my AxCrypt password as normal.

    I can only assume that some of the AxCrypt system is embedded into my OpenOffice since I believe that AxCrypt for Mac does not exist yet and is not shown as a application on my computer.

    I do not fully understand why i can now open the files on my Mac but just very relieved that I can. To be on the safe side I am keeping copies on on a Windows computer.

    Thanks again for your help.

    #4274 Reply


    Hello Keith,

    Something is not right here. My guess is that the files are in fact not encrypted at all, but only renamed to end with “.axx”.

    No, there is no AxCrypt component in OpenOffice (although it would be nice!).

    #4285 Reply


    Hi,  The relevant files in my OpenOffice can only be opened in the AxCrypt window with my AxCrypt password so I assume that they must be encrypted

    #4650 Reply

    Kirk Steinklauber

    I am having some issues on MacOS Sierra and AxCrypt for Mac.  I double click to open the file and the Axcrypt icon shows for a second and then disappears.  What I do is click the AxCrypt again and it shows up without issue and then I close it.

    Then I double click again my file and Axcrypt prompts my password and yes! I can open mi file.  Sometimes it fails and I repeat the previous steps until it opens.  Let’s say that’s fine but what is annoying me now is that every time I open an excel that was previously encrypted (mainly from Windows) and I edit / modify the file and save it with the changes, next time I open the file I get an error from Excel that the file is unreadable and they recover the previous version so my latest changes are basically gone.

    Right now I cannot modify any excel files that are encrypted as they simple breaks (using Excel 2016).  I have not tried other file formats (text files or word documents) to confirm if it’s just with Excel or is a general problem.

    Do anyone on this forum has experienced these issues like I do?


    #4651 Reply


    Hello Kirk,

    There’s actually no current version of AxCrypt for Mac. There is a very old more or less experimental version, but it has not been supported for several years.

    Can you please include a screen shot of AxCrypt in your Mac so we can understand where you’re at so to speak?

    #7587 Reply


    Hello  All,

    AxCrypt for macOS is now released. Get it at .

    #8314 Reply

    Frank Mix

    Does AxCrypt V2 on MAC support updating of encrypted files?  I have mostly Text files and some Microsoft Office files as well. I can only make updates to these files on Windows.

    #8317 Reply


    Hello Frank!

    Yes, AxCrypt on Mac has pretty much the same feature-set as on Windows – but you do need to purchase Premium on the Mac. The Free plan on the Mac only covers viewing and decrypting of encrypted files, not encrypting new files or updating existing encrypted files. Sorry…

    #10496 Reply


    I’m using a MacOS high sierra and I have a problem every time I unlock, make changes to one of my encrypted “.odt” files, save & exit. When I close and re-open the file all of my changes are still there, but when I restart my company the document reverts to how it originally was prior to the changes being made & saved. Thoughts on how to fix this problem?

    #10723 Reply

    David Blanchard


    we have problems on mac os 10.8 and 10.9.

    Install ok but axcrypt can’t be launched.

    Ok on 10.10 and 10.11.

    Can you help us please ?

Viewing 13 posts - 1 through 13 (of 13 total)
Reply To: AxCrypt for Mac OSX 10.12 Sierra
Your information: