Forums Community .AXX file not an Axcrypt file message

This topic contains 6 replies, has 2 voices, and was last updated by  Svante 9 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #4844 Reply

    Mark

    I am getting this message today on a file that has worked for years with Axcrypt.  I uninstalled the old version and installed the new one and still getting this message.  Most of my other files are working fine.  I have one other file that the password is not working even though it is the same as my others.  However, I am really not concerned about that one.  The one I really need access to is the one getting the ‘not an Axcrypt file’ message.

    #4846 Reply

    Svante
    Keymaster

    Hello Mark,

    I’m guessing that the error message mentions something like “GUID Mismatch” also.

    When AxCrypt tries to open or decrypt a file, the first thing it does is check the first 16 bytes of the file content for a “magic sequence of values”, sometimes called a GUID. Each and every file that is encrypted with AxCrypt starts with the same 16 bytes.

    This check fails for two known reasons:

    1) The file is damaged. This kind of damage is known to occur when the file is encrypted with AxCrypt 1.x, and resides on removable media such as a USB drive, and that media is removed from the computer too quickly without using the “Safe Removal” feature of Windows. In this case, the file may not be completely written, and the first part of the file is lost. This does not typically happen with AxCrypt 2, because we’ve improved the structure of the file in this case to avoid this risk. That’s one of the major reasons AxCrypt 2-files are not quite identical to AxCrypt 1-files.

    2) The file is in fact not an AxCrypt file. This typically happens when a user manually renames some file to end with .axx . This causes the file to be associated with AxCrypt, but when AxCrypt tries to open it once again the first thing it does is check those first 16 bytes. If the file then is not an AxCrypt file, you get that message.

    #7765 Reply

    Jean

    I’m getting the same error message when trying to open files that have been encrypted using only AxCrypt 2. In each case, the file appeared fine at the end of the day. The next morning, the file size showed 0 bytes, and the “.AXX file is not an AxCrypt file message” popped up when the password to open the file was entered.

    #7766 Reply

    Louis

    Jean, what version of AxCrypt 2 are you using?

    The current version is 2.1.1536 and can be downloaded from here.

    #7770 Reply

    Svante
    Keymaster

    Hello Jean,

    Are you using version 2.1.1526 ? This was a version that was available for about a day, which included a serious reliability issue which can cause what you describe under certain circumstances (notably, files left open when AxCrypt was automatically signed out). It was withdrawn very quickly.

    If so, you would have received a pop-up message stating you must update because of this. We have a mechanism where we can flag specific versions as “bad”, either for security or for reliability. As long as you allow AxCrypt to connect to the Internet, you will be prompted to upgrade in very strong terms.

    #7775 Reply

    Jean

    Two users are running version 2.1.1516 with no problems.

    The third user upgraded to 2.1.1532.0  when the error messages began appearing, e.g., .AXX file is not an AxCrypt file.   No previous versions are listed in the AxCrypt properties folder to show which version the user was running before the first upgrade. The error messages were still occurring, and the user has now upgraded to version 2.1.1536.

    #7777 Reply

    Svante
    Keymaster

    Hello Jean,

    Unfortunately, if you were using version 2.1.1526, and got the message it means the file itself is damaged. Upgrading won’t help for the damaged file(s), but will prevent it from happening again.

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: .AXX file not an Axcrypt file message
Your information: