Forums Bugs & issues File is not an Axcrypt file

This topic contains 8 replies, has 2 voices, and was last updated by  Svante 1 year, 4 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5109 Reply

    eddie

    I installed AxCrypt-2.1.1489.0 today, the first time I attempted to open a file that was encrypted with AxCrypt-1.7.3180.0 I received a Warning that the file is not an Axcrypt file. I am however able to open other files that were encrypted with the previous version.

    I’ve tried uninstalling the new version and reinstalled the old version, I can no longer open the file with the old version and get an error that the file wasn’t created with Axcrypt, GUI mismatch but again, I can open all of my other files.

    Worst part of this is the file I can’t open is the most important.

     

    #5110 Reply

    Svante
    Keymaster

    Hello eddie,

    This has nothing to do with the upgrade as such. The file in question is indeed either not an AxCrypt file, or more likely unfortunately, damaged to the point where it is no longer recognizable as an AxCrypt file.

    When did you last open the file in question, and more importantly – when did you last modify it?

    #5111 Reply

    eddie

    The file was last opened today and it was modified today, it’s a file I use on a daily basis which has been encrypted with Axcrypt since the file was created. The file not being recognized as an Axcrypt file started immediately after installing the new version, it was the first file I attempted to open after install.

    #5112 Reply

    Svante
    Keymaster

    Hi eddie,

    The file was then damaged during the update today. Hopefully you have a backup of the encrypted file?

    The problem here was not caused by the update of AxCrypt, since the first thing that happened was that it was not recognized.

    This type of damage can happen when a file resides on a removable drive, such as a USB stick, and it is removed without using Windows Safe Removal. Resetting or crashing the system can have the same effect. It has nothing really to do with AxCrypt, it’s how Windows works.

    In fact, with AxCrypt 2, we’ve done some things to mitigate this kind of situation so that if it does happen, chances are at least part of the file can be recovered. In the end though – if something happens stopping Windows from actually writing file contents to a drive, that file will be damaged.

    #5113 Reply

    eddie

    I do have a backup of the file but it’s not as up to date as I’d like it to be, my bad.

    The backup is actually on a removable drive, which is encrypted with the old version as well and its one of the files I’m able to open with the new version, as with all of my other files that were encrypted with the old version.

    I guess I’ll have to suck up the loss.

    #5114 Reply

    Svante
    Keymaster

    Hi eddie,

    Sorry to hear that. So, you’re saying the file in question resides on a local fixed hard drive? It’s pretty much unheard of that an AxCrypt file would be damaged like it appears to have been on a fixed drive.

    Did something unusual happen in the vicinity of the last update of the file? Perhaps a forced reboot by Windows, a power outage, a crash or anything unexpected that could cause a file not to be completely written to disk by AxCrypt?

    #5115 Reply

    Josh

    I don’t know what type of file it is Eddie but if it’s an Office file you can normally get the file back using the ‘Recover’ feature. If it’s created in another type of software then they may have a similar feature.

    If you are using Windows Backup then you might be able to roll-back the changes to the file but it depends on you having activated this beforehand.

    As a last resort you could try looking through the Temp folder and see if any of it is in there.

    #5120 Reply

    eddie

    @svante, yes, the file in question does reside on the local drive and I haven’t experienced any crashes or reboots other than a reboot that I performed in hopes that it might fix the issue.

    It’s possible that the file may have been open during the install of the new version and I closed the file, that may be what caused the issue with the file.

    @Josh, the file is a plain text file. I don’t run Windows backup but I do backup the file, just not as regular as I should, this will teach me!

    I posted here in hopes that it might be something that has happened to others and that there might be a fix but it looks like it’s an isolated case.

    #5121 Reply

    Svante
    Keymaster

    Hi eddie,

    If the file was open during the install of the new version, that at least is a special situation. In that case the upgrade in a way could be related, although it’s a very special case. We have not tried stress testing that particular scenario, but what does happen is that the new software will initiate an uninstall of the old, and that uninstall will in turn ask any running processes to end. It’s supposed to do this in a nice and orderly fashion of course, but it’s not impossible that something could go wrong here causing the old AxCrypt to ended prematurely while writing the updated encrypted file.

    I do not recognize this situation at all, it’s actually a first that I’ve heard of, so it’s certainly a pretty isolated case. Still, I’m very sorry for the inconvenience. We do try to make the software as reliable as possible in as many situations as possible.

Viewing 9 posts - 1 through 9 (of 9 total)
Reply To: File is not an Axcrypt file
Your information: