Forums Bugs & issues Password required after 'timeout'

This topic contains 10 replies, has 2 voices, and was last updated by  Keith 12 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #7102 Reply

    Neutron

    AxCrypt2 (Free) v2.1.1509.0 works as advertised in all ways but one.  Several minutes after I close my AxCrypted file, I must re-enter the password to re-open it, either when the AxCrypt window is not running, or when it is minimized to the Windows Notification Area.  As long as the window is remains displayed, I only need to enter the password once.

    AxCrypt2 is the most recent installation.  When it was first installed, I only needed to enter the password once per Windows session.  Settings:  File > Options > Auto Upgrade 1.x Files is checked.  File > Options > Always Offline is unchecked.  No keys.  Specs:  Windows 10 Home 64bit, Creators Edition v1703, no pen or touch.

    #7103 Reply

    Svante
    Keymaster

    Hello Neutron,

    With the current 2.1.1509 build, you should be automatically signed out when the computer goes to sleep, or the screen saver goes active, or of course if you sign out or actually exit AxCrypt.

    #7104 Reply

    Neutron

    Sleep feature is set to Never for AC and Battery, Screen Saver is set to None, Monitor powers off after 5 minutes idle, Hard Drives power off after 20 minutes idle (but system drive C: is always busy).

    #7105 Reply

    Keith

    I don’t experience the problems you have Neutron and I’ve also got sleep deactivated on my system.

    On my setup, screensaver starts after 45 minutes and monitor off never. In advanced settings I notice that my hard drive is set to power off after 20 minutes.

    I only find AxCrypt signs me out after the screensaver starts therefore I can leave my computer inactive for 44 minutes and AxCrypt is still signed in.

    Maybe something has changed in the Creators Update because I’m using the stable version of Windows: 1607 (14393.1358). I am running the latest version of AxCrypt 2.1.1509.

    Try:

    • increasing the monitor off time or better still disable it and see if the problem reproduces
    • increasing your hard drive turn off time
    • checking ‘allow hybrid sleep’ and also ‘hibernate’ in Advanced Settings

    Maybe Svante has some more input?

    #7149 Reply

    Svante
    Keymaster

    Hello Neutron (and Keith),

    It sounds very strange what you’re describing, since the default really is to stay signed in. Can you perhaps verify if you actually are signed in when you’re being prompted again? This may sound like a silly question, but are you sure that it’s AxCrypt asking for your password?

    #7158 Reply

    Neutron

    (Silliness is only behind the ear of the listener.)  The object requesting my password is definitely AxCrypt v2.1.1509.0 because its own sign-in window requests it.  I am only prompted for a password when I am signed out, regardless if I manually sign out or if AxCrypt automatically signs me out.

    After considering Keith’s suggestions, I:  (<strong style=”color: #080;”>1) Signed in, left AxCrypt’s window open in the background while doing other tasks for about a half hour, kept the monitor active, and found AxCrypt still signed in.  (<strong style=”color: #080;”>2) Signed in, left AxCrypt’s window open, left the computer idle for 5 minutes so the monitor went to low power state, immediately moved the mouse to wake the monitor, and found AxCrypt signed out.  (<strong style=”color: #080;”>3) Signed in, left AxCrypt’s window open, physically powered off the monitor with its power button, waited 65 seconds, physically powered on the monitor, and found AxCrypt still signed in.  (<strong style=”color: #080;”>4) Repeated test <strong style=”color: #080;”>2 a few times to verify that AxCrypt detects either a specific monitor power state change or a low-level command to do so.

    #7159 Reply

    Neutron

    Oops:  Text colors work in your input textarea, but not in the final post.

    #7160 Reply

    Keith

    I’ll try and reproduce the problem on my system Neutron.

    I don’t use ‘monitor off’ but I’ll set it, leave my system with AxCrypt signed in and then wait for it to trigger.

    If I’m signed out then we’ll know it’s because of how AxCrypt interprets the OS signal. If I’m left signed in then we can deduce that something in the Creators Update changed the OS signals.

    #7164 Reply

    Keith

    I’ve reproduced exactly the scenario you describe in AxCrypt 2.1.1509.0 running Windows 1607 (14393.1358):

    AxCrypt signs out when Windows sends the idle timeout signal

    It’s not a bug in either AxCrypt or Windows; this is how Windows notifies other processes/applications that the system is at rest.

    I set the “Display > Turn off display after” to 1 minute whilst AxCrypt was signed in. After the display switched off and I moved the mouse to wake up the system AxCrypt showed as signed out.

    You originally said “When it was first installed, I only needed to enter the password once per Windows session”. I even ran AxCrypt 2.1.1494.0 and there was no difference to this behaviour. I can only assume that you’ve either changed the Display option or that during the Creators Update Microsoft have changed your personal settings (they do this all the time!)

    As AxCrypt signing out whenever the computer is put to sleep (sleep, hibernate, screensaver, display off), locked, logged off, restarted or shutdown this is an intended feature. The only thing you an do is: change the option to an acceptable number of minutes or switch it off altogether.

    #7190 Reply

    Neutron

    When it was first installed“, much about it seemed new and different (it took a while to understand that my exotic file password had to be The password, and still more time to convince myself to trust this); so if I did not let the monitor go idle during that time, then I was likely mistaken about that piece of history.

    In any case there is an alternative:  Make “Auto Sign-out at Screen Idle” optional, Enabled by default for those who leave their hardware unattended and their doors unlocked.

    FWIW:  People who are environmentally responsible and/or unwealthy are more inclined to try to save power and extend monitor life.  It is for both of those reasons that my monitor goes dark after 5 minutes’ idle.

    #7191 Reply

    Keith

    It is a possibility although from what I’ve seen of AxCrypt the want to keep it as simple as possible. Ironically in an upcoming release they’ve introduced an option to sign out after a period of inactivity because people were complaining that it remembers their password for too long!

    I store my exotic password in my password manager which can be set never to lock. I don’t even know my AxCrypt password – I copy and paste it from KeePass whenever I have to. This might be one solution for you.

    Reslistically on modern hardware the monitor off feature is redundant. It saves virtually no power.

Viewing 11 posts - 1 through 11 (of 11 total)
Reply To: Password required after 'timeout'
Your information: